OpenCV problem

classic Classic list List threaded Threaded
23 messages Options
12
Reply | Threaded
Open this post in threaded view
|

OpenCV problem

Eyal Erez
Hello all,

I'm trying to use OpenCV on my Nokia N900, my first goal was to install the libcv4. 

I tried to use X-Terminal sudo gainroot and then apt-get install libcv4, then i got:
Some packages could not be installed. THis may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages ave now yest been created or been moved out of incoming..."
The following information may help to resolve the situation:

The following pakcages have unmet dependencies:
libvcv4: Depends:libavcodec52 (>=3:0.svn20090303-1) but it is not goint to be installed or (lot of spaces) libavcodec-extra-52 (>=3:0.svn20090303-1) but it is not installable
Depends:libavformat52 (>=3:0.svn20090303-1)but it is not going to be installed or (lot of spaces)
libavformat-extra-52 (>=3:0.svn20090303-1) but it is not installable
E:Broken packages.

i tried to install missing lib separte, apt-get install libavcodec52 --->libspeex1 =>package libspeex1 is not available, but is referred to by an other package.... (if this information is important just tell me and i will add the rest of it...)

Then i mailed Daniil Ivanov who was very kind and replay with :
1. Enable Extras-Devel repository.
2. apt-get update
3. apt-get intstall libcv4

but i got the same result, so now i pretty much stuck and dont really know what else i can do , so any help will be very appricate.

My product info is:
Nokia N900
Maemo 5
Version 21.2011.38-1

if any information is needed and missing pls let me know and i will add it,

eyal

_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

shamsul hassan
Hi Eyal,

below link will help .. 

you need to enable Extras-devel or Extras-testing in the repository manager and then apt-get update

Thanks
Shamsul

On Mon, Sep 10, 2012 at 7:23 PM, Eyal Erez <[hidden email]> wrote:
Hello all,

I'm trying to use OpenCV on my Nokia N900, my first goal was to install the libcv4. 

I tried to use X-Terminal sudo gainroot and then apt-get install libcv4, then i got:
Some packages could not be installed. THis may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages ave now yest been created or been moved out of incoming..."
The following information may help to resolve the situation:

The following pakcages have unmet dependencies:
libvcv4: Depends:libavcodec52 (>=3:0.svn20090303-1) but it is not goint to be installed or (lot of spaces) libavcodec-extra-52 (>=3:0.svn20090303-1) but it is not installable
Depends:libavformat52 (>=3:0.svn20090303-1)but it is not going to be installed or (lot of spaces)
libavformat-extra-52 (>=3:0.svn20090303-1) but it is not installable
E:Broken packages.

i tried to install missing lib separte, apt-get install libavcodec52 --->libspeex1 =>package libspeex1 is not available, but is referred to by an other package.... (if this information is important just tell me and i will add the rest of it...)

Then i mailed Daniil Ivanov who was very kind and replay with :
1. Enable Extras-Devel repository.
2. apt-get update
3. apt-get intstall libcv4

but i got the same result, so now i pretty much stuck and dont really know what else i can do , so any help will be very appricate.

My product info is:
Nokia N900
Maemo 5
Version 21.2011.38-1

if any information is needed and missing pls let me know and i will add it,

eyal

_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers



_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Eyal Erez
Hello Shamsul,

Thanks for the resposns.

I enable the Extras-devel repository.
when i write the apt-get update i get a list of update and then(i started from the last line that is good.. ) 
Hit http://repository.maemo.org fremantle/non-free packages
W: Failed to fetch http://repository.maemo.org/dists/fremantle/sdk/fremantle/binary-armel/packages 404 Not Found [IP:81.218.31.152 80]

W:Failed to fetch http://repository.maemo.org/dists/fremantle/sdk/non/binary-armel/packages 404 Not Found [IP:81.218.31.152 80]

E:Some index files failed to download, they have been ignored, or old ones used instead.

and i get the same error, the i mention before about the dependencies...

i will add, that i even tried to surf from the N900 to this site go to 
" Fremantle Extras-devel free armel " libcv4 2.0.0-5 (both of them) and download and install the .deb file and then i get 
"unable to install 'libcv4'. Incompatible application package.
so what else can i do?

eyal

On Mon, Sep 10, 2012 at 9:30 PM, shamsul hassan <[hidden email]> wrote:
Hi Eyal,

below link will help .. 

you need to enable Extras-devel or Extras-testing in the repository manager and then apt-get update

Thanks
Shamsul

On Mon, Sep 10, <a href="tel:2012" value="+9722012" target="_blank">2012 at 7:23 PM, Eyal Erez <[hidden email]> wrote:
Hello all,

I'm trying to use OpenCV on my Nokia N900, my first goal was to install the libcv4. 

I tried to use X-Terminal sudo gainroot and then apt-get install libcv4, then i got:
Some packages could not be installed. THis may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages ave now yest been created or been moved out of incoming..."
The following information may help to resolve the situation:

The following pakcages have unmet dependencies:
libvcv4: Depends:libavcodec52 (>=3:0.svn20090303-1) but it is not goint to be installed or (lot of spaces) libavcodec-extra-52 (>=3:0.svn20090303-1) but it is not installable
Depends:libavformat52 (>=3:0.svn20090303-1)but it is not going to be installed or (lot of spaces)
libavformat-extra-52 (>=3:0.svn20090303-1) but it is not installable
E:Broken packages.

i tried to install missing lib separte, apt-get install libavcodec52 --->libspeex1 =>package libspeex1 is not available, but is referred to by an other package.... (if this information is important just tell me and i will add the rest of it...)

Then i mailed Daniil Ivanov who was very kind and replay with :
1. Enable Extras-Devel repository.
2. apt-get update
3. apt-get intstall libcv4

but i got the same result, so now i pretty much stuck and dont really know what else i can do , so any help will be very appricate.

My product info is:
Nokia N900
Maemo 5
Version 21.2011.38-1

if any information is needed and missing pls let me know and i will add it,

eyal

_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers




_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Abubakar
Hi Shamsul, are you sure your repo is added properly? I have extras-devel link added to fapman (faster application manager) as follows:

Name: extras-devel
Distribution: fremantle-1.3
Components: free non-free

I do a:

~ $ root

and then:

orb:~# apt-get install libcv4

and I get the following:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libavcodec52 libavformat52 libavutil49 libfaad2-0 libtheora0 libvorbis0a
  libvorbisenc2
The following NEW packages will be installed:
  libavcodec52 libavformat52 libavutil49 libcv4 libfaad2-0 libtheora0
  libvorbis0a libvorbisenc2
0 upgraded, 8 newly installed, 0 to remove and 17 not upgraded.
Need to get 5556kB of archives.
After this operation, 13.0MB of additional disk space will be used.
Do you want to continue [Y/n]?

On Mon, Sep 10, 2012 at 11:50 PM, Eyal Erez <[hidden email]> wrote:
Hello Shamsul,

Thanks for the resposns.

I enable the Extras-devel repository.
when i write the apt-get update i get a list of update and then(i started from the last line that is good.. ) 
Hit http://repository.maemo.org fremantle/non-free packages
W: Failed to fetch http://repository.maemo.org/dists/fremantle/sdk/fremantle/binary-armel/packages 404 Not Found [IP:81.218.31.152 80]

W:Failed to fetch http://repository.maemo.org/dists/fremantle/sdk/non/binary-armel/packages 404 Not Found [IP:81.218.31.152 80]

E:Some index files failed to download, they have been ignored, or old ones used instead.

and i get the same error, the i mention before about the dependencies...

i will add, that i even tried to surf from the N900 to this site go to 
" Fremantle Extras-devel free armel " libcv4 2.0.0-5 (both of them) and download and install the .deb file and then i get 
"unable to install 'libcv4'. Incompatible application package.
so what else can i do?

eyal

On Mon, Sep 10, 2012 at 9:30 PM, shamsul hassan <[hidden email]> wrote:
Hi Eyal,

below link will help .. 

you need to enable Extras-devel or Extras-testing in the repository manager and then apt-get update

Thanks
Shamsul

On Mon, Sep 10, <a href="tel:2012" value="+9722012" target="_blank">2012 at 7:23 PM, Eyal Erez <[hidden email]> wrote:
Hello all,

I'm trying to use OpenCV on my Nokia N900, my first goal was to install the libcv4. 

I tried to use X-Terminal sudo gainroot and then apt-get install libcv4, then i got:
Some packages could not be installed. THis may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages ave now yest been created or been moved out of incoming..."
The following information may help to resolve the situation:

The following pakcages have unmet dependencies:
libvcv4: Depends:libavcodec52 (>=3:0.svn20090303-1) but it is not goint to be installed or (lot of spaces) libavcodec-extra-52 (>=3:0.svn20090303-1) but it is not installable
Depends:libavformat52 (>=3:0.svn20090303-1)but it is not going to be installed or (lot of spaces)
libavformat-extra-52 (>=3:0.svn20090303-1) but it is not installable
E:Broken packages.

i tried to install missing lib separte, apt-get install libavcodec52 --->libspeex1 =>package libspeex1 is not available, but is referred to by an other package.... (if this information is important just tell me and i will add the rest of it...)

Then i mailed Daniil Ivanov who was very kind and replay with :
1. Enable Extras-Devel repository.
2. apt-get update
3. apt-get intstall libcv4

but i got the same result, so now i pretty much stuck and dont really know what else i can do , so any help will be very appricate.

My product info is:
Nokia N900
Maemo 5
Version 21.2011.38-1

if any information is needed and missing pls let me know and i will add it,

eyal

_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers




_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers



_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Eyal Erez
Hello Abubaker,

i setup the extras-devel repository by  http://wiki.maemo.org/Extras-devel#How_to_activate_Extras-devel , it says only to write fremantle not fremantle-1.3 but i change it anyway and still i get the same error msg. 

Is there anything else that i can do?? if i will "format" the machine will it help?? what else can i do?

any idea will be apprciate.

eyal

On Mon, Sep 10, 2012 at 10:44 PM, Abubakar <[hidden email]> wrote:
Hi Shamsul, are you sure your repo is added properly? I have extras-devel link added to fapman (faster application manager) as follows:

Name: extras-devel
Distribution: fremantle-1.3
Components: free non-free

I do a:

~ $ root

and then:

orb:~# apt-get install libcv4

and I get the following:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libavcodec52 libavformat52 libavutil49 libfaad2-0 libtheora0 libvorbis0a
  libvorbisenc2
The following NEW packages will be installed:
  libavcodec52 libavformat52 libavutil49 libcv4 libfaad2-0 libtheora0
  libvorbis0a libvorbisenc2
0 upgraded, 8 newly installed, 0 to remove and 17 not upgraded.
Need to get 5556kB of archives.
After this operation, 13.0MB of additional disk space will be used.
Do you want to continue [Y/n]?

On Mon, Sep 10, <a href="tel:2012" value="+9722012" target="_blank">2012 at 11:50 PM, Eyal Erez <[hidden email]> wrote:
Hello Shamsul,

Thanks for the resposns.

I enable the Extras-devel repository.
when i write the apt-get update i get a list of update and then(i started from the last line that is good.. ) 
Hit http://repository.maemo.org fremantle/non-free packages
W: Failed to fetch http://repository.maemo.org/dists/fremantle/sdk/fremantle/binary-armel/packages 404 Not Found [IP:81.218.31.152 80]

W:Failed to fetch http://repository.maemo.org/dists/fremantle/sdk/non/binary-armel/packages 404 Not Found [IP:81.218.31.152 80]

E:Some index files failed to download, they have been ignored, or old ones used instead.

and i get the same error, the i mention before about the dependencies...

i will add, that i even tried to surf from the N900 to this site go to 
" Fremantle Extras-devel free armel " libcv4 <a href="tel:2.0.0-5" value="+9722005" target="_blank">2.0.0-5 (both of them) and download and install the .deb file and then i get 
"unable to install 'libcv4'. Incompatible application package.
so what else can i do?

eyal

On Mon, Sep 10, <a href="tel:2012" value="+9722012" target="_blank">2012 at 9:30 PM, shamsul hassan <[hidden email]> wrote:
Hi Eyal,

below link will help .. 

you need to enable Extras-devel or Extras-testing in the repository manager and then apt-get update

Thanks
Shamsul

On Mon, Sep 10, <a href="tel:2012" value="+9722012" target="_blank">2012 at 7:23 PM, Eyal Erez <[hidden email]> wrote:
Hello all,

I'm trying to use OpenCV on my Nokia N900, my first goal was to install the libcv4. 

I tried to use X-Terminal sudo gainroot and then apt-get install libcv4, then i got:
Some packages could not be installed. THis may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages ave now yest been created or been moved out of incoming..."
The following information may help to resolve the situation:

The following pakcages have unmet dependencies:
libvcv4: Depends:libavcodec52 (>=3:0.svn20090303-1) but it is not goint to be installed or (lot of spaces) libavcodec-extra-52 (>=3:0.svn20090303-1) but it is not installable
Depends:libavformat52 (>=3:0.svn20090303-1)but it is not going to be installed or (lot of spaces)
libavformat-extra-52 (>=3:0.svn20090303-1) but it is not installable
E:Broken packages.

i tried to install missing lib separte, apt-get install libavcodec52 --->libspeex1 =>package libspeex1 is not available, but is referred to by an other package.... (if this information is important just tell me and i will add the rest of it...)

Then i mailed Daniil Ivanov who was very kind and replay with :
1. Enable Extras-Devel repository.
2. apt-get update
3. apt-get intstall libcv4

but i got the same result, so now i pretty much stuck and dont really know what else i can do , so any help will be very appricate.

My product info is:
Nokia N900
Maemo 5
Version 21.2011.38-1

if any information is needed and missing pls let me know and i will add it,

eyal

_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers




_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers



_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers



_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Daniil Ivanov-2
Hi Eyal!

Could you please post full output of apt-get update,
so we can see what exactly configured and was update successful or not.

You can save  do it conveniently by saving output to a file:
apt-get update &> my.log
Just in case: "pwd" shows a current working path where file is saved.

Thanks, Daniil

On Tue, Sep 11, 2012 at 8:19 PM, Eyal Erez <[hidden email]> wrote:
Hello Abubaker,

i setup the extras-devel repository by  http://wiki.maemo.org/Extras-devel#How_to_activate_Extras-devel , it says only to write fremantle not fremantle-1.3 but i change it anyway and still i get the same error msg. 

Is there anything else that i can do?? if i will "format" the machine will it help?? what else can i do?

any idea will be apprciate.

eyal


On Mon, Sep 10, 2012 at 10:44 PM, Abubakar <[hidden email]> wrote:
Hi Shamsul, are you sure your repo is added properly? I have extras-devel link added to fapman (faster application manager) as follows:

Name: extras-devel
Distribution: fremantle-1.3
Components: free non-free

I do a:

~ $ root

and then:

orb:~# apt-get install libcv4

and I get the following:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libavcodec52 libavformat52 libavutil49 libfaad2-0 libtheora0 libvorbis0a
  libvorbisenc2
The following NEW packages will be installed:
  libavcodec52 libavformat52 libavutil49 libcv4 libfaad2-0 libtheora0
  libvorbis0a libvorbisenc2
0 upgraded, 8 newly installed, 0 to remove and 17 not upgraded.
Need to get 5556kB of archives.
After this operation, 13.0MB of additional disk space will be used.
Do you want to continue [Y/n]?

On Mon, Sep 10, <a href="tel:2012" value="+9722012" target="_blank">2012 at 11:50 PM, Eyal Erez <[hidden email]> wrote:
Hello Shamsul,

Thanks for the resposns.

I enable the Extras-devel repository.
when i write the apt-get update i get a list of update and then(i started from the last line that is good.. ) 
Hit http://repository.maemo.org fremantle/non-free packages
W: Failed to fetch http://repository.maemo.org/dists/fremantle/sdk/fremantle/binary-armel/packages 404 Not Found [IP:81.218.31.152 80]

W:Failed to fetch http://repository.maemo.org/dists/fremantle/sdk/non/binary-armel/packages 404 Not Found [IP:81.218.31.152 80]

E:Some index files failed to download, they have been ignored, or old ones used instead.

and i get the same error, the i mention before about the dependencies...

i will add, that i even tried to surf from the N900 to this site go to 
" Fremantle Extras-devel free armel " libcv4 <a href="tel:2.0.0-5" value="+9722005" target="_blank">2.0.0-5 (both of them) and download and install the .deb file and then i get 
"unable to install 'libcv4'. Incompatible application package.
so what else can i do?

eyal

On Mon, Sep 10, <a href="tel:2012" value="+9722012" target="_blank">2012 at 9:30 PM, shamsul hassan <[hidden email]> wrote:
Hi Eyal,

below link will help .. 

you need to enable Extras-devel or Extras-testing in the repository manager and then apt-get update

Thanks
Shamsul

On Mon, Sep 10, <a href="tel:2012" value="+9722012" target="_blank">2012 at 7:23 PM, Eyal Erez <[hidden email]> wrote:
Hello all,

I'm trying to use OpenCV on my Nokia N900, my first goal was to install the libcv4. 

I tried to use X-Terminal sudo gainroot and then apt-get install libcv4, then i got:
Some packages could not be installed. THis may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages ave now yest been created or been moved out of incoming..."
The following information may help to resolve the situation:

The following pakcages have unmet dependencies:
libvcv4: Depends:libavcodec52 (>=3:0.svn20090303-1) but it is not goint to be installed or (lot of spaces) libavcodec-extra-52 (>=3:0.svn20090303-1) but it is not installable
Depends:libavformat52 (>=3:0.svn20090303-1)but it is not going to be installed or (lot of spaces)
libavformat-extra-52 (>=3:0.svn20090303-1) but it is not installable
E:Broken packages.

i tried to install missing lib separte, apt-get install libavcodec52 --->libspeex1 =>package libspeex1 is not available, but is referred to by an other package.... (if this information is important just tell me and i will add the rest of it...)

Then i mailed Daniil Ivanov who was very kind and replay with :
1. Enable Extras-Devel repository.
2. apt-get update
3. apt-get intstall libcv4

but i got the same result, so now i pretty much stuck and dont really know what else i can do , so any help will be very appricate.

My product info is:
Nokia N900
Maemo 5
Version 21.2011.38-1

if any information is needed and missing pls let me know and i will add it,

eyal

_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers




_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers



_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers



_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers



_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Abubakar
yes do ..
apt-get clean
apt-get update

On Mon, Sep 17, 2012 at 4:14 PM, Daniil Ivanov <[hidden email]> wrote:
Hi Eyal!

Could you please post full output of apt-get update,
so we can see what exactly configured and was update successful or not.

You can save  do it conveniently by saving output to a file:
apt-get update &> my.log
Just in case: "pwd" shows a current working path where file is saved.

Thanks, Daniil


On Tue, Sep 11, 2012 at 8:19 PM, Eyal Erez <[hidden email]> wrote:
Hello Abubaker,

i setup the extras-devel repository by  http://wiki.maemo.org/Extras-devel#How_to_activate_Extras-devel , it says only to write fremantle not fremantle-1.3 but i change it anyway and still i get the same error msg. 

Is there anything else that i can do?? if i will "format" the machine will it help?? what else can i do?

any idea will be apprciate.

eyal


On Mon, Sep 10, 2012 at 10:44 PM, Abubakar <[hidden email]> wrote:
Hi Shamsul, are you sure your repo is added properly? I have extras-devel link added to fapman (faster application manager) as follows:

Name: extras-devel
Distribution: fremantle-1.3
Components: free non-free

I do a:

~ $ root

and then:

orb:~# apt-get install libcv4

and I get the following:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libavcodec52 libavformat52 libavutil49 libfaad2-0 libtheora0 libvorbis0a
  libvorbisenc2
The following NEW packages will be installed:
  libavcodec52 libavformat52 libavutil49 libcv4 libfaad2-0 libtheora0
  libvorbis0a libvorbisenc2
0 upgraded, 8 newly installed, 0 to remove and 17 not upgraded.
Need to get 5556kB of archives.
After this operation, 13.0MB of additional disk space will be used.
Do you want to continue [Y/n]?

On Mon, Sep 10, <a href="tel:2012" value="+9722012" target="_blank">2012 at 11:50 PM, Eyal Erez <[hidden email]> wrote:
Hello Shamsul,

Thanks for the resposns.

I enable the Extras-devel repository.
when i write the apt-get update i get a list of update and then(i started from the last line that is good.. ) 
Hit http://repository.maemo.org fremantle/non-free packages
W: Failed to fetch http://repository.maemo.org/dists/fremantle/sdk/fremantle/binary-armel/packages 404 Not Found [IP:81.218.31.152 80]

W:Failed to fetch http://repository.maemo.org/dists/fremantle/sdk/non/binary-armel/packages 404 Not Found [IP:81.218.31.152 80]

E:Some index files failed to download, they have been ignored, or old ones used instead.

and i get the same error, the i mention before about the dependencies...

i will add, that i even tried to surf from the N900 to this site go to 
" Fremantle Extras-devel free armel " libcv4 <a href="tel:2.0.0-5" value="+9722005" target="_blank">2.0.0-5 (both of them) and download and install the .deb file and then i get 
"unable to install 'libcv4'. Incompatible application package.
so what else can i do?

eyal

On Mon, Sep 10, <a href="tel:2012" value="+9722012" target="_blank">2012 at 9:30 PM, shamsul hassan <[hidden email]> wrote:
Hi Eyal,

below link will help .. 

you need to enable Extras-devel or Extras-testing in the repository manager and then apt-get update

Thanks
Shamsul

On Mon, Sep 10, <a href="tel:2012" value="+9722012" target="_blank">2012 at 7:23 PM, Eyal Erez <[hidden email]> wrote:
Hello all,

I'm trying to use OpenCV on my Nokia N900, my first goal was to install the libcv4. 

I tried to use X-Terminal sudo gainroot and then apt-get install libcv4, then i got:
Some packages could not be installed. THis may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages ave now yest been created or been moved out of incoming..."
The following information may help to resolve the situation:

The following pakcages have unmet dependencies:
libvcv4: Depends:libavcodec52 (>=3:0.svn20090303-1) but it is not goint to be installed or (lot of spaces) libavcodec-extra-52 (>=3:0.svn20090303-1) but it is not installable
Depends:libavformat52 (>=3:0.svn20090303-1)but it is not going to be installed or (lot of spaces)
libavformat-extra-52 (>=3:0.svn20090303-1) but it is not installable
E:Broken packages.

i tried to install missing lib separte, apt-get install libavcodec52 --->libspeex1 =>package libspeex1 is not available, but is referred to by an other package.... (if this information is important just tell me and i will add the rest of it...)

Then i mailed Daniil Ivanov who was very kind and replay with :
1. Enable Extras-Devel repository.
2. apt-get update
3. apt-get intstall libcv4

but i got the same result, so now i pretty much stuck and dont really know what else i can do , so any help will be very appricate.

My product info is:
Nokia N900
Maemo 5
Version 21.2011.38-1

if any information is needed and missing pls let me know and i will add it,

eyal

_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers




_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers



_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers



_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers




_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Abubakar
sending my email again, the last one got held cuz it exceeded 20k in the body message. Strange.
Anyway I wrote:

oh :) ... sorry for the misunderstanding

since you wrote:

> Could you please post full output of apt-get update, 

I was further telling  Eyal that do a "apt-get clean" first and then the "update" of it, and then paste the logs here.
Just wanted him to do a "clean" first.

On Mon, Sep 17, 2012 at 5:00 PM, Daniil Ivanov <[hidden email]> wrote:
Hi Abubakar,

  I have to confess I don't really understand your message. According to
  you previous mail everything is working fine and as expected for you.

Thanks, Daniil.




_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Eyal Erez
Hello

i did the:
apt-get clear  , and i got new line i think it's ok.
but then i wrote apt-get update &>eyal.log and it writes a lot of stuff  and then the errors i wrote before, but i dont get a new line until i will press enter..

then i use midnight Comm in order to copy the file to a place where i can use(copy to windows 8 file system) or using the mail app to send it (i cant reach it using the nokia pc-connectivity or the mass storage.. ) but it seems the file is empty...

eyal

On Mon, Sep 17, 2012 at 3:07 PM, Abubakar <[hidden email]> wrote:
sending my email again, the last one got held cuz it exceeded 20k in the body message. Strange.
Anyway I wrote:

oh :) ... sorry for the misunderstanding

since you wrote:

> Could you please post full output of apt-get update, 

I was further telling  Eyal that do a "apt-get clean" first and then the "update" of it, and then paste the logs here.
Just wanted him to do a "clean" first.

On Mon, Sep 17, <a href="tel:2012" value="+9722012" target="_blank">2012 at 5:00 PM, Daniil Ivanov <[hidden email]> wrote:
Hi Abubakar,

  I have to confess I don't really understand your message. According to
  you previous mail everything is working fine and as expected for you.

Thanks, Daniil.




_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers



_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Daniil Ivanov-2
On Tue, Sep 18, 2012 at 7:30 PM, Eyal Erez <[hidden email]> wrote:
> but then i wrote apt-get update &>eyal.log and it writes a lot of stuff and
> then the errors i wrote before, but i dont get a new line until i will press
> enter..

This command redirects both error stream and output stream to a file, you should
see exactly nothing until apt-get quits. Also I didn't notice you were
mentioning
errors at update phase. Could you please provide exact error messages?

> then i use midnight Comm in order to copy the file to a place where i can
> use(copy to windows 8 file system) or using the mail app to send it (i cant
> reach it using the nokia pc-connectivity or the mass storage.. ) but it
> seems the file is empty...

In mass storage mode /home/user/MyDocs/ gets mounted to your PC.
However, when you start X terminal a working directory is /home/user/
So to make it easier for yourself you have two options:
1. Use ssh with USB-networking. AFAIK it didn't work on Windows 7,
does Windows 8 has a driver for networking over USB?
2. Execute "cd MyDocs" before apt-get update &> eyal.log, then mount
phone to PC in Mass storage mode and copy the file.

Also consider using Linux for Linux development. It will make your life easier.

Thanks, Daniil
_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Eyal Erez
I'm thinking about using linux, i even install it, but i'm not familier with that and i'm not that familier with Nokia OS(Meamo) so i try minimize that things that i don't know ..

i type "apt-get quits" and i get : "E:Invalid opertion quits"
then i type "exit" twice and close the X-Terminal and still the file is empty.
what can i do to solve this?
i also check and i can reach the file in windows but i's empty 

The error msg that i get are :

"Hit http://repository.maemo.org fremantle/non-free packages
W: Failed to fetch http://repository.maemo.org/dists/fremantle/sdk/fremantle/binary-armel/packages 404 Not Found [IP:81.218.31.152 80]

W:Failed to fetch http://repository.maemo.org/dists/fremantle/sdk/non/binary-armel/packages 404 Not Found [IP:81.218.31.152 80]

E:Some index files failed to download, they have been ignored, or old ones used instead."

Thank,
Eyal

On Tue, Sep 18, 2012 at 8:21 PM, Daniil Ivanov <[hidden email]> wrote:
On Tue, Sep 18, <a href="tel:2012" value="+9722012">2012 at 7:30 PM, Eyal Erez <[hidden email]> wrote:
> but then i wrote apt-get update &>eyal.log and it writes a lot of stuff and
> then the errors i wrote before, but i dont get a new line until i will press
> enter..

This command redirects both error stream and output stream to a file, you should
see exactly nothing until apt-get quits. Also I didn't notice you were
mentioning
errors at update phase. Could you please provide exact error messages?

> then i use midnight Comm in order to copy the file to a place where i can
> use(copy to windows 8 file system) or using the mail app to send it (i cant
> reach it using the nokia pc-connectivity or the mass storage.. ) but it
> seems the file is empty...

In mass storage mode /home/user/MyDocs/ gets mounted to your PC.
However, when you start X terminal a working directory is /home/user/
So to make it easier for yourself you have two options:
1. Use ssh with USB-networking. AFAIK it didn't work on Windows 7,
does Windows 8 has a driver for networking over USB?
2. Execute "cd MyDocs" before apt-get update &> eyal.log, then mount
phone to PC in Mass storage mode and copy the file.

Also consider using Linux for Linux development. It will make your life easier.

Thanks, Daniil


_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Daniil Ivanov-2
On Tue, Sep 18, 2012 at 10:39 PM, Eyal Erez <[hidden email]> wrote:
> I'm thinking about using linux, i even install it, but i'm not familier with
> that and i'm not that familier with Nokia OS(Meamo) so i try minimize that
> things that i don't know ..

The name of OS is Maemo, and it's actually Debian based, so it shares
many tools with Debian and Ubuntu, making it much easier to do things
there.

> i type "apt-get quits" and i get : "E:Invalid opertion quits"

Whenever in future you have doubts about what commands parameters are
and what they actually do,
consult their manual pages:
http://linux.die.net/man/8/apt-get

> then i type "exit" twice and close the X-Terminal and still the file is
> empty.
> what can i do to solve this?
> i also check and i can reach the file in windows but i's empty

I'm puzzled why this happens for you. Maybe you interrupt apt-get
before it's able to produce
any error messages.

> The error msg that i get are :
>
> "Hit http://repository.maemo.org fremantle/non-free packages
> W: Failed to fetch
> http://repository.maemo.org/dists/fremantle/sdk/fremantle/binary-armel/packages
> 404 Not Found [IP:81.218.31.152 80]
>
> W:Failed to fetch
> http://repository.maemo.org/dists/fremantle/sdk/non/binary-armel/packages
> 404 Not Found [IP:81.218.31.152 80]
>
> E:Some index files failed to download, they have been ignored, or old ones
> used instead."

I don't have N900 any more, so I cannot check. But it looks like it's
related to configuration of Nokia closed source packages. You need to
fetch the key afer signing the EULA and let apt know the key as it's
explained in the page
http://tablets-dev.nokia.com/eula/index.php

This command will show the content of apt current configuration in command line:
cat /etc/apt/sources.list

Thanks, Daniil.
_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Daniil Ivanov-2
Could anyone please share content of /etc/apt/sources.list
and /etc/apt/sources.list.d/ from their N900 for a cross check?

Thanks, Daniil

On Wed, Sep 19, 2012 at 12:55 PM, Daniil Ivanov <[hidden email]> wrote:

> I don't have N900 any more, so I cannot check. But it looks like it's
> related to configuration of Nokia closed source packages. You need to
> fetch the key afer signing the EULA and let apt know the key as it's
> explained in the page
> http://tablets-dev.nokia.com/eula/index.php
>
> This command will show the content of apt current configuration in command line:
> cat /etc/apt/sources.list
>
> Thanks, Daniil.
_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Abubakar
sorry i didnt do a reply-all, so sending again:

my /etc/apt/sources.list is empty.

/etc/apt/souces.list.d/ has "hildon-application-manager.list" which contains:


On Thu, Sep 20, 2012 at 11:34 AM, Daniil Ivanov <[hidden email]> wrote:
Could anyone please share content of /etc/apt/sources.list
and /etc/apt/sources.list.d/ from their N900 for a cross check?

Thanks, Daniil

On Wed, Sep 19, 2012 at 12:55 PM, Daniil Ivanov <[hidden email]> wrote:
> I don't have N900 any more, so I cannot check. But it looks like it's
> related to configuration of Nokia closed source packages. You need to
> fetch the key afer signing the EULA and let apt know the key as it's
> explained in the page
> http://tablets-dev.nokia.com/eula/index.php
>
> This command will show the content of apt current configuration in command line:
> cat /etc/apt/sources.list
>
> Thanks, Daniil.
_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers


_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Daniil Ivanov-2
Thank you very mych, Abubakar!

As I expected there is no really SDK repository as it's not meant to
be used on the device.
My guess would be that apt configuration on Eyal's N900 was messed up
at some point and now
have to be restored to pristine state to work again.

Thanks, Daniil

On Thu, Sep 20, 2012 at 10:54 AM, Abubakar <[hidden email]> wrote:

> sorry i didnt do a reply-all, so sending again:
>
> my /etc/apt/sources.list is empty.
>
> /etc/apt/souces.list.d/ has "hildon-application-manager.list" which
> contains:
>
> deb https://downloads.maemo.nokia.com/fremantle/ssu/apps/ ./
> deb https://downloads.maemo.nokia.com/fremantle/ssu/003 ./
> deb https://downloads.maemo.nokia.com/fremantle1.2/ovi/ ./
> deb http://repository.maemo.org/extras/ fremantle-1.3 free non-free
> deb http://repository.maemo.org/extras-devel/ fremantle-1.3 free non-free
>
> On Thu, Sep 20, 2012 at 11:34 AM, Daniil Ivanov <[hidden email]>
> wrote:
>>
>> Could anyone please share content of /etc/apt/sources.list
>> and /etc/apt/sources.list.d/ from their N900 for a cross check?
>>
>> Thanks, Daniil
>>
>> On Wed, Sep 19, 2012 at 12:55 PM, Daniil Ivanov <[hidden email]>
>> wrote:
>> > I don't have N900 any more, so I cannot check. But it looks like it's
>> > related to configuration of Nokia closed source packages. You need to
>> > fetch the key afer signing the EULA and let apt know the key as it's
>> > explained in the page
>> > http://tablets-dev.nokia.com/eula/index.php
>> >
>> > This command will show the content of apt current configuration in
>> > command line:
>> > cat /etc/apt/sources.list
>> >
>> > Thanks, Daniil.
>> _______________________________________________
>> maemo-developers mailing list
>> [hidden email]
>> https://lists.maemo.org/mailman/listinfo/maemo-developers
>
>
>
> _______________________________________________
> maemo-developers mailing list
> [hidden email]
> https://lists.maemo.org/mailman/listinfo/maemo-developers
>
_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Eyal Erez
Well, that's doesn't sound good for me. 

So is there a manual how to reset the phone, in a way that i will ensure that i could work with OpenCV afterwards??

Again, thank u very much for the help and info
Great appreciation to all.

eyal

On Thu, Sep 20, 2012 at 2:29 PM, Daniil Ivanov <[hidden email]> wrote:
Thank you very mych, Abubakar!

As I expected there is no really SDK repository as it's not meant to
be used on the device.
My guess would be that apt configuration on Eyal's N900 was messed up
at some point and now
have to be restored to pristine state to work again.

Thanks, Daniil

On Thu, Sep 20, <a href="tel:2012" value="+9722012">2012 at 10:54 AM, Abubakar <[hidden email]> wrote:
> sorry i didnt do a reply-all, so sending again:
>
> my /etc/apt/sources.list is empty.
>
> /etc/apt/souces.list.d/ has "hildon-application-manager.list" which
> contains:
>
> deb https://downloads.maemo.nokia.com/fremantle/ssu/apps/ ./
> deb https://downloads.maemo.nokia.com/fremantle/ssu/003 ./
> deb https://downloads.maemo.nokia.com/fremantle1.2/ovi/ ./
> deb http://repository.maemo.org/extras/ fremantle-1.3 free non-free
> deb http://repository.maemo.org/extras-devel/ fremantle-1.3 free non-free
>
> On Thu, Sep 20, <a href="tel:2012" value="+9722012">2012 at 11:34 AM, Daniil Ivanov <[hidden email]>
> wrote:
>>
>> Could anyone please share content of /etc/apt/sources.list
>> and /etc/apt/sources.list.d/ from their N900 for a cross check?
>>
>> Thanks, Daniil
>>
>> On Wed, Sep 19, <a href="tel:2012" value="+9722012">2012 at 12:55 PM, Daniil Ivanov <[hidden email]>
>> wrote:
>> > I don't have N900 any more, so I cannot check. But it looks like it's
>> > related to configuration of Nokia closed source packages. You need to
>> > fetch the key afer signing the EULA and let apt know the key as it's
>> > explained in the page
>> > http://tablets-dev.nokia.com/eula/index.php
>> >
>> > This command will show the content of apt current configuration in
>> > command line:
>> > cat /etc/apt/sources.list
>> >
>> > Thanks, Daniil.
>> _______________________________________________
>> maemo-developers mailing list
>> [hidden email]
>> https://lists.maemo.org/mailman/listinfo/maemo-developers
>
>
>
> _______________________________________________
> maemo-developers mailing list
> [hidden email]
> https://lists.maemo.org/mailman/listinfo/maemo-developers
>
_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers


_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Abubakar
Well one option is to flash your phone and you can read instructions here http://wiki.maemo.org/Updating_the_tablet_firmware
You can use the built-in Backup application to take a backup, put it on your pc and flash the cell phone and then transfer back the backup to phone and restore it (using mass storage option).
That flashing info page contains info for many maemo devces other then n900, so try to focus on the right things :)

On Fri, Sep 21, 2012 at 9:07 PM, Eyal Erez <[hidden email]> wrote:
Well, that's doesn't sound good for me. 

So is there a manual how to reset the phone, in a way that i will ensure that i could work with OpenCV afterwards??

Again, thank u very much for the help and info
Great appreciation to all.

eyal



_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Daniil Ivanov-2
Apparently, it would be much easier to place content you've posted to
/etc/apt/souces.list.d/hildon-application-manager.list
and make sure that /etc/apt/sources.list is empty.

Thanks, Daniil

On Fri, Sep 21, 2012 at 9:03 PM, Abubakar <[hidden email]> wrote:

> Well one option is to flash your phone and you can read instructions here
> http://wiki.maemo.org/Updating_the_tablet_firmware.
> You can use the built-in Backup application to take a backup, put it on your
> pc and flash the cell phone and then transfer back the backup to phone and
> restore it (using mass storage option).
> That flashing info page contains info for many maemo devces other then n900,
> so try to focus on the right things :)
>
> On Fri, Sep 21, 2012 at 9:07 PM, Eyal Erez <[hidden email]> wrote:
>>
>> Well, that's doesn't sound good for me.
>>
>> So is there a manual how to reset the phone, in a way that i will ensure
>> that i could work with OpenCV afterwards??
>>
>> Again, thank u very much for the help and info
>> Great appreciation to all.
>>
>> eyal
>>
>>
>
> _______________________________________________
> maemo-developers mailing list
> [hidden email]
> https://lists.maemo.org/mailman/listinfo/maemo-developers
>
_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Eyal Erez
Ok so to the Result:

i added the lines that were missing in the  /etc/apt/souces.list.d/"hildon-application-manager.list" file. as abubakar wrote.
did apt-get update
and then apt-get install libcv4 -->and it's seems to be working.

now First of ALL i want to thank Daniil and abubakar for all the help...

thanks a lot guys.

now does anybody know how i can check that everything is working , some small code to check the system?

Again thanks a lot guys




On Fri, Sep 21, 2012 at 8:31 PM, Daniil Ivanov <[hidden email]> wrote:
Apparently, it would be much easier to place content you've posted to
/etc/apt/souces.list.d/hildon-application-manager.list
and make sure that /etc/apt/sources.list is empty.

Thanks, Daniil

On Fri, Sep 21, <a href="tel:2012" value="+9722012">2012 at 9:03 PM, Abubakar <[hidden email]> wrote:
> Well one option is to flash your phone and you can read instructions here
> http://wiki.maemo.org/Updating_the_tablet_firmware.
> You can use the built-in Backup application to take a backup, put it on your
> pc and flash the cell phone and then transfer back the backup to phone and
> restore it (using mass storage option).
> That flashing info page contains info for many maemo devces other then n900,
> so try to focus on the right things :)
>
> On Fri, Sep 21, <a href="tel:2012" value="+9722012">2012 at 9:07 PM, Eyal Erez <[hidden email]> wrote:
>>
>> Well, that's doesn't sound good for me.
>>
>> So is there a manual how to reset the phone, in a way that i will ensure
>> that i could work with OpenCV afterwards??
>>
>> Again, thank u very much for the help and info
>> Great appreciation to all.
>>
>> eyal
>>
>>
>
> _______________________________________________
> maemo-developers mailing list
> [hidden email]
> https://lists.maemo.org/mailman/listinfo/maemo-developers
>


_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
Reply | Threaded
Open this post in threaded view
|

Re: OpenCV problem

Daniil Ivanov-2
You are welcome!
GNU/Linux consist of a lot of subsystems. Each must be checked to make
sure everything is working properly. On the other hand, when something is
not working, user will likely notice, so no need for a code.

Thanks, Daniil

On Mon, Sep 24, 2012 at 6:56 PM, Eyal Erez <[hidden email]> wrote:

> Ok so to the Result:
>
> i added the lines that were missing in the
> /etc/apt/souces.list.d/"hildon-application-manager.list" file. as abubakear
> wrote.
> did apt-get update
> and then apt-get install libcv4 -->and it's seems to be working.
>
> now First of ALL i want to thank Daniil and abubakar for all the help...
>
> thanks a lot guys.
>
> now does anybody know how i can check that everything is working , some
> small code to check the system?
>
> Again thanks a lot guys
>
>
>
>
> On Fri, Sep 21, 2012 at 8:31 PM, Daniil Ivanov <[hidden email]>
> wrote:
>>
>> Apparently, it would be much easier to place content you've posted to
>> /etc/apt/souces.list.d/hildon-application-manager.list
>> and make sure that /etc/apt/sources.list is empty.
>>
>> Thanks, Daniil
>>
>> On Fri, Sep 21, 2012 at 9:03 PM, Abubakar <[hidden email]> wrote:
>> > Well one option is to flash your phone and you can read instructions
>> > here
>> > http://wiki.maemo.org/Updating_the_tablet_firmware.
>> > You can use the built-in Backup application to take a backup, put it on
>> > your
>> > pc and flash the cell phone and then transfer back the backup to phone
>> > and
>> > restore it (using mass storage option).
>> > That flashing info page contains info for many maemo devces other then
>> > n900,
>> > so try to focus on the right things :)
>> >
>> > On Fri, Sep 21, 2012 at 9:07 PM, Eyal Erez <[hidden email]> wrote:
>> >>
>> >> Well, that's doesn't sound good for me.
>> >>
>> >> So is there a manual how to reset the phone, in a way that i will
>> >> ensure
>> >> that i could work with OpenCV afterwards??
>> >>
>> >> Again, thank u very much for the help and info
>> >> Great appreciation to all.
>> >>
>> >> eyal
>> >>
>> >>
>> >
>> > _______________________________________________
>> > maemo-developers mailing list
>> > [hidden email]
>> > https://lists.maemo.org/mailman/listinfo/maemo-developers
>> >
>
>
>
> _______________________________________________
> maemo-developers mailing list
> [hidden email]
> https://lists.maemo.org/mailman/listinfo/maemo-developers
>
_______________________________________________
maemo-developers mailing list
[hidden email]
https://lists.maemo.org/mailman/listinfo/maemo-developers
12